All Deployments: Billing Page issues for Credit Card Transactions
Incident Report for Duo
Resolved
After monitoring for several hours, we have confirmed that credit card transactions are processing without issue. We have not seen any evidence of an ongoing problem. We will continue working to improve the reliability of our payment processing.
Posted Feb 18, 2021 - 13:20 EST
Monitoring
Credit card transactions are now completing successfully in the Duo Admin Panel. Our Engineering Team is continuing to monitor the issue to confirm it is fully resolved.
We will continue to update this incident.
Posted Feb 18, 2021 - 09:05 EST
Investigating
We are currently investigating reports of customers not being able to make payments via the 'Billing' tab in the Duo Admin panel. Further updates will be posted as they are made available.
Posted Feb 18, 2021 - 06:46 EST
This incident affected: DUO6 (Admin Panel), DUO61 (Admin Panel), DUO12 (Admin Panel), DUO36 (Admin Panel), DUO59 (Admin Panel), DUO42 (Admin Panel), DUO65 (Admin Panel), DUO40 (Admin Panel), DUO11 (Admin Panel), DUO55 (Admin Panel), DUO30 (Admin Panel), DUO2 (Admin Panel), DUO25 (Admin Panel), DUO14 (Admin Panel), DUO57 (Admin Panel), DUO60 (Admin Panel), DUO3 (Admin Panel), DUO52 (Admin Panel), DUO21 (Admin Panel), DUO66 (Admin Panel), DUO64 (Admin Panel), DUO33 (Admin Panel), DUO50 (Admin Panel), DUO49 (Admin Panel), DUO58 (Admin Panel), DUO9 (Admin Panel), DUO53 (Admin Panel), DUO46 (Admin Panel), DUO43 (Admin Panel), DUO48 (Admin Panel), DUO41 (Admin Panel), DUO37 (Admin Panel), DUO44 (Admin Panel), DUO28 (Admin Panel), DUO23 (Admin Panel), DUO26 (Admin Panel), DUO20 (Admin Panel), DUO15 (Admin Panel), DUO13 (Admin Panel), DUO7 (Admin Panel), DUO5 (Admin Panel), DUO47 (Admin Panel), DUO31 (Admin Panel), DUO10 (Admin Panel), DUO19 (Admin Panel), DUO29 (Admin Panel), DUO4 (Admin Panel), DUO27 (Admin Panel), DUO51 (Admin Panel), DUO34 (Admin Panel), DUO8 (Admin Panel), DUO54 (Admin Panel), DUO62 (Admin Panel), DUO63 (Admin Panel), DUO56 (Admin Panel), DUO17 (Admin Panel), DUO22 (Admin Panel), DUO45 (Admin Panel), DUO24 (Admin Panel), DUO18 (Admin Panel), DUO16 (Admin Panel), DUO32 (Admin Panel), DUO38 (Admin Panel), DUO39 (Admin Panel), DUO1 (Admin Panel), and DUO35 (Admin Panel).