General internet routing issues
Incident Report for Duo Security
Resolved
The routing issues with the ISPs and peering providers appear to have subsided and traffic appears to be routing as normal.
Posted 5 months ago. Jun 29, 2018 - 20:36 EDT
Investigating
We are investigating several reports from customers that are using particular ISPs that have connectivity issues to Duo. Initial details seem to stem from an issue with a peering provider that several ISPs use. We will continue to investigate and provide an update as we have more details. Duo's services continue to operate as normal assuming a stable network route. Please contact your ISP and consult their status page for updates as well.
Posted 5 months ago. Jun 29, 2018 - 17:25 EDT