Duo Support Phone System Issue
Incident Report for Duo
Resolved
We have resolved the issue impacting the support phone number listed on the Duo Admin Panel, as well as the Federal and VIP phone numbers.
Posted Jul 09, 2024 - 14:13 EDT
Identified
We have identified the issue impacting the support phone number listed on the Duo Admin Panel, as well as the Federal and VIP phone numbers and are working towards a resolution. As a workaround, please use our other regionalized numbers found at https://duo.com/support or send an email to support@duo.com.
Posted Jul 09, 2024 - 12:42 EDT
Investigating
We are currently investigating an issue with reachability to the phone number listed on Duo's Admin Panel, as well as the Federal and VIP phone numbers. As a workaround, please use our other regionalized numbers found at https://duo.com/support or send an email to support@duo.com.
Posted Jul 09, 2024 - 11:00 EDT
This incident affected: Duo Support (Phone Support).