Phone Support Handling Issue
Incident Report for Duo
Resolved
Our support call system provider has resolved the issues and now inbound calls are being routed successfully. All customers whose calls we have missed due to this issue have now also received a call back. Thank you for your patience.
Posted Jan 07, 2021 - 18:03 EST
Investigating
We have been made aware of a service disruption impacting Duo's phone system. Our provider's engineers are working on addressing the issue as soon as possible. In the meantime, we suggest contacting us via email or chat. Please check back here or subscribe to updates for any changes.
Posted Jan 07, 2021 - 16:29 EST
This incident affected: Duo Support (Phone Support).