Blank Duo Prompt issue impacting users authenticating from both Chrome and Edge version 136 browsers and Epic Hyperdrive

Incident Report for Duo

Postmortem

Summary

An apparent defect in v136 of Chromium-based browsers (such as Google Chrome and Microsoft Edge) caused newly added code in Duo’s web-based prompt, when interacting with Duo Desktop, to freeze or crash the browser tab. The issue was specific to version 136; all other versions did not exhibit the problem. Duo has deployed a fix to ensure this behavior is not present in these versions.

Timeline of Events

  • 8/29/2025 1:25am EST - Duo engineering is alerted of a customer reporting the issue
  • 8/29/2025 1:22pm EST - Incident created
  • 8/29/2025 9:35pm EST - Started deploying the update to fix the issue
  • 8/29/2025 11:36pm EST - Finished deploying the update to fix the issue
  • 8/30/2025 12:07am EST - Status page is updated to monitoring
  • 8/30/2025 1:02am EST - Status page is updated to resolved

Details

Updates were added to D322 to check whether the Chrome Local Network Access permission setting was enabled in the browser being used to authenticate. The Local Network Access permission is being added to Chromium-based browsers in v141, and changes were added to improve the user experience if the Local Network Access permission is not enabled. More details can be found in this Duo Knowledge Base article. In v136 of Chromium-based browsers, the change that was added to check the Local Network Access permission caused the browser to freeze or crash.

To resolve this issue, Duo added a change to not check the Chrome Local Network Access permission if v136 of a Chromium based browser is being used. Since the Chrome Local Network Access permission is being released in v141, this change did not have any negative impact.

Duo will explore adding additional testing and alerting for issues like this one, where only specific browser versions are impacted by an issue.

Posted Sep 03, 2025 - 11:10 EDT

Resolved

The issue causing the blank prompt is now resolved and full functionality is restored.

We will be posting a root-cause analysis (RCA) here once our engineering team has finished its thorough investigation of the issue.
Posted Aug 30, 2025 - 01:03 EDT

Monitoring

A fix has been deployed for the blank prompt issue affecting Chrome/Edge version 136.
We are monitoring the results of the fix at this time.

Please check back here or subscribe to updates for any changes.
Posted Aug 30, 2025 - 00:05 EDT

Identified

We are currently aware of an issue that is impacting users logging into web-based applications from both Chrome and Edge version 136 that causes a blank Duo Prompt to appear.

We are working on a fix for this issue urgently and hope to provide an update soon. As a workaround, if users upgrade their browser to a newer version, authentication will work as normal, which is also a recommended best practice for security as well.

Additionally, users logging into Epic Hyperdrive may also experience this issue when attempting to log in, and our fix will also apply to that application once released. As a temporary workaround, you can downgrade Hyperdrive to 100.2506.3, which will move to a lower Chromium Version (134.0.6998.205) and no longer see the issue.

As soon as our fix has been released, we'll provide an update as soon as possible.
Posted Aug 29, 2025 - 13:30 EDT
This incident affected: DUO1 (Core Authentication Service), DUO2 (Core Authentication Service), DUO3 (Core Authentication Service), DUO4 (Core Authentication Service), DUO5 (Core Authentication Service), DUO6 (Admin Panel), DUO7 (Core Authentication Service), DUO8 (Core Authentication Service), DUO47 (Core Authentication Service), DUO10 (Core Authentication Service), DUO11 (Core Authentication Service), DUO12 (Core Authentication Service), DUO13 (Core Authentication Service), DUO14 (Core Authentication Service), DUO15 (Core Authentication Service), DUO16 (Core Authentication Service), DUO17 (Core Authentication Service), DUO18 (Core Authentication Service), DUO19 (Core Authentication Service), DUO20 (Core Authentication Service), DUO21 (Core Authentication Service), DUO22 (Core Authentication Service), DUO23 (Core Authentication Service), DUO24 (Core Authentication Service), DUO25 (Core Authentication Service), DUO26 (Core Authentication Service), DUO27 (Core Authentication Service), DUO28 (Core Authentication Service), DUO29 (Core Authentication Service), DUO30 (Core Authentication Service), DUO31 (Core Authentication Service), DUO32 (Core Authentication Service), DUO33 (Core Authentication Service), DUO34 (Core Authentication Service), DUO36 (Core Authentication Service), DUO37 (Core Authentication Service), DUO38 (Core Authentication Service), DUO39 (Core Authentication Service), DUO40 (Core Authentication Service), DUO41 (Core Authentication Service), DUO42 (Core Authentication Service), DUO43 (Core Authentication Service), DUO44 (Core Authentication Service), DUO45 (Core Authentication Service), DUO46 (Core Authentication Service), DUO48 (Core Authentication Service), DUO9 (Core Authentication Service), DUO49 (Core Authentication Service), DUO50 (Core Authentication Service), DUO51 (Core Authentication Service), DUO52 (Core Authentication Service), DUO53 (Core Authentication Service), DUO54 (Core Authentication Service), DUO55 (Core Authentication Service), DUO56 (Core Authentication Service), DUO57 (Core Authentication Service), DUO58 (Core Authentication Service), DUO59 (Core Authentication Service), DUO60 (Core Authentication Service), DUO62 (Core Authentication Service), DUO63 (Core Authentication Service), DUO64 (Core Authentication Service), DUO65 (Core Authentication Service), DUO66 (Core Authentication Service), DUO67 (Core Authentication Service), DUO68 (Core Authentication Service), DUO69 (Core Authentication Service), DUO70 (Core Authentication Service), DUO71 (Core Authentication Service), DUO72 (Core Authentication Service), DUO73 (Core Authentication Service), DUO74 (Core Authentication Service), DUO75 (Core Authentication Service), DUO76 (Core Authentication Service), DUO77 (Core Authentication Service), DUO78 (Core Authentication Service), DUO79 (Core Authentication Service), DUO80 (Core Authentication Service), DUO81 (Core Authentication Service), and DUO35 (Core Authentication Service).