We remain in active coordination with our cloud service provider as they work to resolve a power outage affecting a primary data center. Connectivity issues and elevated error rates across the region will persist until power has been fully restored. The provider has indicated that full restoration and environment stabilization may take a day or more. Our next update will follow within 6 hours.
Posted Mar 02, 2026 - 15:27 EST
Update
Our cloud provider is responding to a power outage at a primary data center that continues to cause elevated error rates and connectivity issues across the region. While early signs of recovery were observed, the provider has since confirmed the impact is ongoing. Full restoration and environment stability are expected to take several hours.
We will provide our next update within 6 hours.
Posted Mar 02, 2026 - 09:44 EST
Update
We are continuing to work on a fix for this issue.
Posted Mar 02, 2026 - 09:00 EST
Update
We are continuing to work on a fix for this issue.
Posted Mar 02, 2026 - 04:01 EST
Identified
We have isolated the issue to a regional outage and are working with our partners to alleviate the degraded performance.
Posted Mar 02, 2026 - 04:01 EST
Update
We are continuing to investigate this issue.
Posted Mar 02, 2026 - 03:31 EST
Investigating
We are currently investigating a service degradation on our DUO81 deployment and are working to restore services as soon as possible.