Duo Support Phone System Issue
Incident Report for Duo
Resolved
The issue with call handling for our Duo Support Team has been resolved.
Posted Dec 19, 2024 - 11:09 EST
Identified
We have identified an issue with Phone Support availability for our Duo Support Team and are working to deploy a fix.

If you need to submit a case, please utilize the Duo Support Portal or send us an email to support@duo.com
Posted Dec 19, 2024 - 10:26 EST
This incident affected: Duo Support (Phone Support).