Multiple deployments: Authentication latency for some customers
Incident Report for Duo
Resolved
This issue is now confirmed to be fully resolved.
Posted Nov 02, 2021 - 18:59 EDT
Monitoring
The issue is resolved, and we are actively monitoring the behavior for any recurrences.
Posted Nov 02, 2021 - 17:44 EDT
Investigating
We are currently investigating an issue that is causing increased latency with authentication for all methods, as well as access to the Duo Admin Panel for a very small number of customers for some customers on the following deployments:

DUO26
DUO34
DUO43
DUO46
DUO51

We are working urgently on correcting this issue, and will provide an update as soon as it is available.
Posted Nov 02, 2021 - 16:28 EDT
This incident affected: DUO51 (Core Authentication Service, Admin Panel, Push Delivery, Phone Call Delivery, SMS Message Delivery, Cloud PKI), DUO26 (Core Authentication Service, Admin Panel, Push Delivery, Phone Call Delivery, SMS Message Delivery, Cloud PKI), DUO46 (Core Authentication Service, Admin Panel, Push Delivery, Phone Call Delivery, SMS Message Delivery, Cloud PKI), DUO43 (Core Authentication Service, Admin Panel, Push Delivery, Phone Call Delivery, SMS Message Delivery, Cloud PKI), and DUO34 (Core Authentication Service, Admin Panel, Push Delivery, Phone Call Delivery, SMS Message Delivery, Cloud PKI, SSO).