Phone Support Handling Issue
Incident Report for Duo
Resolved
Support phone call connectivity issues have been resolved.
All support calls are operational.
Posted Mar 15, 2022 - 22:06 EDT
Monitoring
Support phone call connectivity issues have been resolved and we are currently monitoring for stability.
Posted Mar 15, 2022 - 16:35 EDT
Investigating
Duo Support is currently investigating an issue disrupting call connectivity between customers and our Support Engineers. We are working with the appropriate teams to address the core issue.

If you need to contact Duo Support, we recommend contacting us via email for less urgent matters.
Posted Mar 15, 2022 - 15:59 EDT
This incident affected: Duo Support (Phone Support).