15 Minute Federal Maintenance Outage Scheduled for May 31st, 2024
Incident Report for Duo
Resolved
This incident was set accidentally and will be marked as resolved.
Please see https://status.duo.com/incidents/ky1sp9cdptws for the updated maintenance information.
Posted May 30, 2024 - 17:25 EDT
Identified
Cisco Duo’s Federal edition will be performing necessary system maintenance and upgrades. To make this possible, the Duo Federal edition will have a scheduled downtime on Friday, May 31, 2024, at 12:00am EDT. Maintenance is expected to take one hour and will resolve by 1am EDT. No further action is required.

We appreciate your understanding as we work to improve your Duo Federal edition experience. If you have any questions, please reach out to support@duo.com. We also encourage you to subscribe to Duo Release Notes; improvements and enhancements to the Duo Federal edition will be shared there moving forward.

Thank you for being a Cisco Duo customer!
Posted May 30, 2024 - 10:50 EDT
This incident affected: DUO61 (Core Authentication Service, Admin Panel, Push Delivery, Phone Call Delivery, SMS Message Delivery, Cloud PKI).