Duo Access and Authentication Failures on DUO69
Incident Report for Duo
Resolved
We have resolved the issue that was causing access and authentication issues on our DUO69 deployment.
All services are now fully functional.
Posted Jun 04, 2024 - 17:33 EDT
Monitoring
A fix has been implemented for the issue impacting authentication and access to the Duo Admin Panel on our DUO69 deployment.

We will continue to monitor the issue and will post any updates when the incident is considered fully resolved.
Posted Jun 04, 2024 - 17:26 EDT
Investigating
We are currently investigating an issue causing authentication and access to the Duo Admin Panel on our DUO69 deployment and are working to correct the issue as soon as possible.
Please check back here or subscribe to updates for any changes.
Posted Jun 04, 2024 - 17:21 EDT
This incident affected: DUO69 (Core Authentication Service, Admin Panel, Push Delivery, Phone Call Delivery, SMS Message Delivery, Cloud PKI, SSO).