Duo Support: Phone Routing Issues

Incident Report for Duo

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 15:05 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2025 - 13:07 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 17, 2025 - 12:53 EDT

Investigating

We are currently investigating reports that our phone numbers are routing to the incorrect endpoints and are working with our internal teams to resolve the issue as soon as possible. If you need to submit a case, please utilize the Duo Support Portal or send us an email to support@duo.com.
Posted Jul 17, 2025 - 11:44 EDT
This incident affected: Duo Support (Phone Support).