New Duo Trial Signup Failures

Incident Report for Duo

Resolved

The issue affecting Duo Trial signups has been resolved.
Posted Dec 19, 2025 - 16:03 EST

Monitoring

We have deployed a fix for the issue causing Duo Trial signups to fail and are monitoring the results of the fix at this time.
Posted Dec 19, 2025 - 15:24 EST

Identified

We have identified the cause of the issue affecting Duo trial signups and are actively working on a fix. Additional updates will be shared as progress is made.
Posted Dec 19, 2025 - 14:12 EST

Investigating

We are currently investigating an issue causing new Duo Trial signups to fail.

We are working to restore this capability as soon as possible and will provide additional updates here as progress is made.

Please check back here or subscribe to updates for any changes.
Posted Dec 19, 2025 - 12:59 EST