All Deployments: Microsoft DNS Resolution Issue Causing Azure CA Authentication Failures
Incident Report for Duo
Resolved
As of 21:49 UTC, all Duo Azure Conditional Access authentications successfully reached Microsoft services, and we have not observed a failure due to the DNS routing issue since that time. Microsoft confirmed that the DNS issue was resolved in public cloud instances as of 23:05 UTC.

Per Microsoft’s Status Page at https://azure.microsoft.com/en-us/status/ :

Current Status: Between 21:00 and 23:05 UTC on 29 Jan 2019, there was a DNS service event with Level 3 as a DNS provider which affected the Azure Public Cloud. Engineers continue to work on some residual impact in Azure Government Cloud.

For customers using Azure Monitor, there was a period of time where alerts, including Service Health alerts, did not fire.

Customer Impact: Some customers using the Azure Government Cloud may experience residual issues accessing Microsoft Cloud resources, as well as intermittent authentication issues across multiple Azure services. Steps have been taken to fail over to an alternative DNS provider, and recovery is currently being validated.

Next Update: 01:30 UTC on 30th Jan 2019
Posted Jan 29, 2019 - 19:16 EST
Monitoring
Authentication success rates are back to expected levels as of approximately 20 minutes ago, although it’s unclear when the issue will be fully resolved.

According to Microsoft’s Status Page at https://azure.microsoft.com/en-us/status/:

Starting at 21:00 UTC on 29 Jan 2019, customers may experience issues accessing Microsoft Cloud resources. Engineers are pursuing multiple workstreams to isolate the root cause and mitigate impact. The next update will be provided in 60 minutes or as events warrant.
Posted Jan 29, 2019 - 17:15 EST
Investigating
We are investigating a Microsoft issue causing intermittent authentication failures with Azure Conditional Access applications that appear to be related to DNS resolution issues reaching Microsoft’s domains in certain regions.

Microsoft is aware of the issue and are currently investigating per https://twitter.com/AzureSupport/status/1090360382466605056

@AzureSupport: Engineers are investigating a Microsoft networking issue impacting customers' ability to log in to the Azure Portal. More information will be provided as it becomes available.

Please check back here or subscribe to updates for any changes.
Posted Jan 29, 2019 - 16:41 EST
This incident affected: DUO1 (Core Authentication Service), DUO2 (Core Authentication Service), DUO3 (Core Authentication Service), DUO4 (Core Authentication Service), DUO5 (Core Authentication Service), DUO6 (Admin Panel), DUO7 (Core Authentication Service), DUO8 (Core Authentication Service), DUO47 (Core Authentication Service), DUO10 (Core Authentication Service), DUO11 (Core Authentication Service), DUO12 (Core Authentication Service), DUO13 (Core Authentication Service), DUO14 (Core Authentication Service), DUO15 (Core Authentication Service), DUO16 (Core Authentication Service), DUO17 (Core Authentication Service), DUO18 (Core Authentication Service), DUO19 (Core Authentication Service), DUO20 (Core Authentication Service), DUO21 (Core Authentication Service), DUO22 (Core Authentication Service), DUO23 (Core Authentication Service), DUO24 (Core Authentication Service), DUO25 (Core Authentication Service), DUO26 (Core Authentication Service), DUO27 (Core Authentication Service), DUO28 (Core Authentication Service), DUO29 (Core Authentication Service), DUO30 (Core Authentication Service), DUO31 (Core Authentication Service), DUO32 (Core Authentication Service), DUO33 (Core Authentication Service), DUO34 (Core Authentication Service), DUO36 (Core Authentication Service), DUO37 (Core Authentication Service), DUO38 (Core Authentication Service), DUO39 (Core Authentication Service), DUO40 (Core Authentication Service), DUO41 (Core Authentication Service), DUO42 (Core Authentication Service), DUO43 (Core Authentication Service), DUO44 (Core Authentication Service), DUO45 (Core Authentication Service), DUO46 (Core Authentication Service), DUO48 (Core Authentication Service), DUO9 (Core Authentication Service), DUO49 (Core Authentication Service), DUO50 (Core Authentication Service), DUO51 (Core Authentication Service), DUO52 (Core Authentication Service), DUO53 (Core Authentication Service), DUO54 (Core Authentication Service), DUO55 (Core Authentication Service), DUO56 (Core Authentication Service), DUO57 (Core Authentication Service), DUO58 (Core Authentication Service), DUO59 (Core Authentication Service), DUO60 (Core Authentication Service), DUO61 (Core Authentication Service), and DUO35 (Core Authentication Service).