SMS Message Delivery to some US numbers
Incident Report for Duo
Resolved
We've successfully confirmed stability with our load balanced SMS delivery. Duo SMS delivery will no longer be impacted at this time. If you encounter further SMS delivery issues, please create a support ticket and these issues will be handled accordingly.
Posted Nov 16, 2022 - 12:19 EST
Monitoring
We are currently monitoring third-party provider issues causing failures with SMS Message Delivery to some US numbers on all of our deployments.

We are load-balancing SMS delivery across various providers which have resulted in an improvement in delivery.

We will continue to monitor the issues with providers and will post any updates when the incident is considered fully resolved.
Posted Nov 11, 2022 - 21:00 EST
Investigating
We are currently investigating an issue causing failures with SMS Message Delivery to some US numbers.

Please check back here or subscribe to updates for any changes.
Posted Nov 11, 2022 - 18:29 EST
This incident affected: DUO45 (SMS Message Delivery), DUO49 (SMS Message Delivery), and DUO63 (SMS Message Delivery).