The issue causing authentication failures on DUO57 with the Duo Core Authentication Service is now resolved and full functionality has been restored.
Posted May 13, 2026 - 12:03 EDT
Monitoring
We have implemented a fix for the issue causing authentication failures on DUO57 with the Duo Core Authentication Service.
We will continue to monitor system performance and authentication success rates and will provide further updates once the incident is fully resolved.
Posted May 13, 2026 - 11:37 EDT
Identified
We have identified the cause of the issue causing authentication failures on DUO57 with the Duo Core Authentication Service and are actively working to restore service.
Posted May 13, 2026 - 10:52 EDT
Investigating
We are currently investigating an issue causing limited authentication failures on DUO57 and are working to correct the issue as soon as possible.
Posted May 13, 2026 - 09:22 EDT
This incident affected: DUO57 (Core Authentication Service).