Duo Support Phone System Issue

Incident Report for Duo

Resolved

The issue affecting call connectivity between customers and our Support Engineers has been resolved.
Posted Dec 23, 2025 - 03:59 EST

Monitoring

A fix has been implemented to resolve the call connectivity issue between customers and our Support Engineers. We are currently monitoring the situation with the appropriate teams to ensure continued service stability.
Posted Dec 23, 2025 - 03:33 EST

Identified

Duo Support has identified the issue disrupting call connectivity between customers and our Support Engineers and is actively working with the appropriate teams to address the core issue. If you need to contact Duo Support, we recommend using alternative channels such as email (support@duo.com) or the Support Portal. We apologize for the inconvenience and appreciate your patience as we work to resolve this issue.
Posted Dec 23, 2025 - 02:56 EST

Investigating

Duo Support is currently investigating an issue disrupting call connectivity between customers and our Support Engineers. We are working with the appropriate teams to address the core issue. If you need to contact Duo Support, we recommend contacting us via alternative channels of Email (support@duo.com) and Support Portal.
Posted Dec 23, 2025 - 02:35 EST
This incident affected: Duo Support (Phone Support).