We have tested from multiple providers and are able to confirm that key presses are registering successfully again.
Posted Jun 30, 2025 - 16:55 EDT
Identified
We have identified the issue causing the Duo Support phone number to not be able to accept key presses in the phone tree. This issue relates to a problem with our backend phone provider and we are working with them to get it corrected as soon as possible.
In the meantime, please use our phone numbers found on our website below: https://duo.com/support
Posted Jun 30, 2025 - 15:00 EDT
Investigating
We are currently investigating issues with our Duo Support phone number found in the Admin Panel where key presses are not detected in phone tree.
In the meantime, please use our phone numbers found on our website below: https://duo.com/support
Posted Jun 30, 2025 - 11:18 EDT
This incident affected: Duo Support (Phone Support).