[DUO19] Duo Authentication Failures
Incident Report for Duo
Resolved
Following a period of monitoring, we have confirmed that the authentication issues impacting DUO19 are now fully resolved.
Posted Sep 16, 2024 - 20:53 EDT
Identified
We have identified an issue affecting authentication on DUO19 and are working to correct the issue as soon as possible. Please check back here or subscribe to updates for any changes.
Posted Sep 16, 2024 - 20:44 EDT
This incident affected: DUO19 (Core Authentication Service).