US Deployments: Failed SMS delivery for T-Mobile customers
Incident Report for Duo
Resolved
The issue with SMS delivery failures to T-Mobile is now confirmed to be fully resolved.
Posted Mar 22, 2022 - 09:39 EDT
Monitoring
We are observing recovery in SMS delivery failures for T-Mobile customers on all of our US based deployments with a small percentage of failures.

Please subscribe to the status page for further updates.
Posted Mar 21, 2022 - 22:42 EDT
Identified
Our telephony vendor has identified the issue causing failed SMS delivery for T-Mobile customers on all of our US based deployments. Delivery failures started at 9:44 pm UTC.

Please subscribe to the status page for further updates.
Posted Mar 21, 2022 - 19:38 EDT
Investigating
We are currently investigating an issue causing failed SMS delivery for T-Mobile customers on all of our US based deployments and are working to correct the issue as soon as possible.

Please check back here or subscribe to updates for any changes.
Posted Mar 21, 2022 - 19:15 EDT
This incident affected: DUO5 (SMS Message Delivery), DUO44 (SMS Message Delivery), DUO26 (SMS Message Delivery), DUO30 (SMS Message Delivery), DUO14 (SMS Message Delivery), DUO63 (SMS Message Delivery), DUO49 (SMS Message Delivery), DUO42 (SMS Message Delivery), DUO55 (SMS Message Delivery), DUO9 (SMS Message Delivery), DUO20 (SMS Message Delivery), DUO19 (SMS Message Delivery), DUO34 (SMS Message Delivery), DUO28 (SMS Message Delivery), DUO11 (SMS Message Delivery), DUO54 (SMS Message Delivery), DUO4 (SMS Message Delivery), DUO48 (SMS Message Delivery), DUO12 (SMS Message Delivery), DUO64 (SMS Message Delivery), DUO25 (SMS Message Delivery), DUO65 (SMS Message Delivery), DUO46 (SMS Message Delivery), DUO60 (SMS Message Delivery), DUO27 (SMS Message Delivery), DUO50 (SMS Message Delivery), DUO8 (SMS Message Delivery), DUO40 (SMS Message Delivery), DUO58 (SMS Message Delivery), DUO43 (SMS Message Delivery), DUO32 (SMS Message Delivery), DUO24 (SMS Message Delivery), DUO2 (SMS Message Delivery), DUO45 (SMS Message Delivery), DUO16 (SMS Message Delivery), DUO41 (SMS Message Delivery), DUO6 (SMS Message Delivery), DUO13 (SMS Message Delivery), DUO18 (SMS Message Delivery), DUO37 (SMS Message Delivery), DUO7 (SMS Message Delivery), DUO15 (SMS Message Delivery), DUO10 (SMS Message Delivery), DUO21 (SMS Message Delivery), DUO36 (SMS Message Delivery), DUO23 (SMS Message Delivery), DUO51 (SMS Message Delivery), DUO62 (SMS Message Delivery), DUO31 (SMS Message Delivery), DUO47 (SMS Message Delivery), DUO3 (SMS Message Delivery), DUO1 (SMS Message Delivery), DUO52 (SMS Message Delivery), DUO39 (SMS Message Delivery), DUO29 (SMS Message Delivery), DUO56 (SMS Message Delivery), DUO61 (SMS Message Delivery), DUO59 (SMS Message Delivery), DUO33 (SMS Message Delivery), DUO22 (SMS Message Delivery), DUO17 (SMS Message Delivery), and DUO35 (SMS Message Delivery).