The issue causing login failures and "Invalid Credentials" messages when attempting to access the Duo Admin Panel on the DUO50 deployment has been fully resolved.
Posted Jun 06, 2025 - 10:13 EDT
Monitoring
We have deployed a fix for the issue causing login failures and "Invalid Credentials" messages when attempting to access the Duo Admin Panel on the DUO50 deployment. We are monitoring the results of the fix at this time.
Posted Jun 06, 2025 - 09:58 EDT
Identified
We have identified the issue causing login failures and "Invalid Credentials" messages when attempting to access the Duo Admin Panel on the DUO50 deployment. We are working to deploy a fix at this time.
Posted Jun 06, 2025 - 09:45 EDT
Investigating
We are currently investigating an issue causing login failures and "Invalid Credentials" messages when attempting to access the Duo Admin Panel on the DUO50 deployment.
Please feel free to check back here or subscribe to updates for the latest information regarding any changes or resolutions.